mshd.net
当前位置:首页 >> Struts2需要用哪些包 >>

Struts2需要用哪些包

早在struts2.0.*的时候,struts2的必备jar包需要如下几个: commons-logging-*.jar Apache旗下commons项目的log日志包 freemarker-*.jar 一种前台页面模板,应用比较广泛 ognl-*.jar 动态图导航语言,struts2处理前台页面的核心语言,相当实用 s...

看你要什么需求了,最基本的5个包不能少,分别是commons-logging-api-1.1.jar,freemarker-2.3.16.jar,ognl-3.0.jar,struts2-core-2.2.1.1.jar,xwork-core-2.2.1.1.jar 如果需要上传文件就需要commons-fileupload-1.2.1.jar,若要用到json则...

先把所有的struts文件下载,最基本的jar包(满足最简单struts运行起来的)可以去下载好的struts文件中struts-2.3.15.1-all\struts-2.3.15.1\apps\struts2-blank\WEB-INF\lib下去复制。其他的用到什么去struts-2.3.15.1-all\struts-2.3.15.1\lib...

struts2.1.6 支持jar包 xwork-2.1.2.jar struts2-core-2.1.6.jar commons-logging-1.0.4.jar freemarker-2.3.13.jar ognl-2.6.11.jar commons-fileupload-1.2.1.jar spring2.5.6支持jar包 spring.jar cglib-nodep-2.1_3.jar dom4j-1.6.1.jar log...

普通的开发需要五个, ognl.jar, struts2-spring-plugin-2.x.jar, commons-logging-1.X.jar ,struts2-core-2.x.jar, xwork-2.x.jar, freemark-2.x.jar。 当然随着你的业务肯能需要更多的jar文件

strust2 官网,apache网站上有比较完整下载压缩包 ~ ~ ~

struts2-blank.war\WEB-INF\lib\* struts2-blank.war\WEB-INF\src\java\strust.xml lib\struts2-spring-plugin-2.2.3.jar spring-framework-2.5.1-with-dependencies.zip\spring-framework-2.5.1\lib\aspectj\*.jar spring-framework-2.5.1-with...

struts2需要的几个jar包: 1)xwork-core-2.1.6 2)struts2-core-2.1.8 3)ognl-2.7.3 4)freemarker-2.3.15 5)commons-io-1.3.2 6)commons-fileupload-1.2.1 这是最常用的几个包,没有这几个包是不行的

只需要配置好struts2就可以用,不用加额外的jar,使用时在页面调用下命名空间就行了

一般这五个包就够了freemarker-2.3.22.jar, ognl-3.0.6.jar, struts2-core-2.3.24.1.jar, commons-logging-1.1.3.jar, xwork-core-2.3.24.1.jar, 我的全部包是struts-2.3.24.1-all

网站首页 | 网站地图
All rights reserved Powered by www.mshd.net
copyright ©right 2010-2021。
内容来自网络,如有侵犯请联系客服。zhit325@qq.com