mshd.net
当前位置:首页 >> AnDroiD vAluEs%v21 >>

AnDroiD vAluEs%v21

values-v11代表在API 11+的设备上,用该目录下的styles.xml代替res/values/styles.xml values-v14代表在API 14+的设备上,用该目录下的styles.xml代替res/values/styles.xml 其中API 11+代表android 3.0 + 其中API 14+代表android 4.0 +

[ Answer ] : In your build.gradle (Module gradle) file you should update the values to the following: android { compileSdkVersion 23 buildToolsVersion '23.0.0'

是因为你的Android版本没有,你点击项目属性,添加Android版本就行了

选中res文件夹

Android tools 升级22.6.2,在创建工程时只要选择的最低版本低于4.0,就会自动生成一个项目appcompat_v7,会自动创建。其实创建了也没关系,你就自己进入activity删掉标红的地方,删除res里边错误的style或者只要在创建工程的时候选择不创建Acti...

我也是这样,我发现网上出现这样的问题,很多都是最近几天出现的,

哎,这个问题是因为你在建立工程时,最低版本低于4.0导致的,新建工程时把版本最低设置到4.0以上 就不会出现appcompat_v7这个兼容库了,至于怎么兼容4,.0以下的,我正是在解决这个问题的过程中搜到了你这个问题。。。等我解决了再给你回复答案吧

你这个貌似是使用了android5.0的东西,但是没有源码,导致了values21不可用,删掉就可以了

android每一个系统版本都对应一个编号的 21代表安卓5.0系统,23代表安卓6.0系统,具体可以看下面的图

试试把minSdkVersion数值提高点 例如14 出现这种情况,是不是因为你升级的 android sdk? 有疑问还可以追问哦,如有需要还可以QQ协助。

网站首页 | 网站地图
All rights reserved Powered by www.mshd.net
copyright ©right 2010-2021。
内容来自网络,如有侵犯请联系客服。zhit325@qq.com