mshd.net
当前位置:首页 >> jDk1.8下mAvEn3.3.3报错版本不对.除了用jDk1.6,还... >>

jDk1.8下mAvEn3.3.3报错版本不对.除了用jDk1.6,还...

maven 3.3 .3貌似还不支持jdk8,我也遇到了这问题,最后换了7好了官网貌似说支持7及以上的版本,但是确实不行。不过java多版本可以同时存在,你不想删除8可以重新再装个7或6,alias命令动态切换java版本就可以了。 具体操作: 1、打开终端 cd到根...

方法/步骤 使用maven的时候,默认会使用1.5版本的JDK,并且也是编译成1.5的,我的电脑里面用的JDK是1.7的,1.8也出来了,没理由还用1.5的吧!所以我手动改成了1.7,郁闷的是,每次 maven-update project 的时候,又变成1.5的了 查阅了相关资料后...

搞错了吧 Maven 3.3 requires JDK 1.7 or above to execute - it still allows you to build against 1.3 and other JDK versions by Using Toolchains

ock org.apache.maven.plugins maven-compiler-plugin 2.3.2 1.6 1.6

maven3.3.9 对jdk的版本有要求 ock org.apache.maven.plugins maven-compiler-plugin 2.3.2 1.6 1.6

解决方法,重新下载这个jar包。先去.m2目录下删除此jar包,点击项目名右键--->refresh;看有没有重新下载。如果有下载成功,就ok了;若没有则关掉eclipse重启。

我用的是maven3.3.9,Myeclipse10版本,配置Maven时发现无法选择JDK版本,只能选择默认的JDK1.6,应该是Myeclipse自带的那个,点击Add也添加不上,我电脑上安装的是JDK1.8,是因为maven还不支持jdk1.8吗?

maven3.3.9 是可以支持JDK 1.8的,先把你的myeclipse升级到最新版本吧。myeclipse10应该只支持1.6的。

Upgrade Java minimum version prerequisite from Java 6 to Java 7 最低要求 jdk 7

Detected Maven Version: 2.1-SNAPSHOT is not in the allowed range 3.0.3. 你当前使用的是maven2.1 而这个pom要求3.0.3,如果你安装了多个maven,注意环境变量。 Detected JDK Version: 1.5.0-11 is not in the allowed range 1.6. 你安装的JD...

网站首页 | 网站地图
All rights reserved Powered by www.mshd.net
copyright ©right 2010-2021。
内容来自网络,如有侵犯请联系客服。zhit325@qq.com