mshd.net
当前位置:首页 >> linux安装rpm包时有的有依赖关系,如何强制安装? >>

linux安装rpm包时有的有依赖关系,如何强制安装?

1.加上 --nodeps,意思不考虑依赖 2.更狠的--force,强制安装 你可以在这两个之前试试--aid自己解决依赖

这是一个软件包管理器,强制安装说明有病毒,电脑管家安全报告统计过很多此类情况了 下载软件的时候以后都小心一些,不要下载不明来路的软件 另外用电脑管家工具箱的软件管理功能去下载软件,可以避免这情况。

1.加上 --nodeps,意思不考虑依赖2.更狠的--force,强制安装你可以在这两个之前试试--aid自己解决依赖

RPM是RPM Package Manager(RPM软件包管理器)的缩写,是已编译的二进制程序包,执行如下命令即可安装。 rpm -ivh 要安装的rpm文件包 以安装vsftd程序包为例,执行效果如下图所示:

哪有自己依赖自己的rpm包的呢,截图上面的提示信息的意思是needed by,是某某rpm包“被......依赖”的意思,所以“needed by”前面的名字才是安装时依赖的软件包,这个软件包依赖的应该是libcom_err-devel和pkgconfig(com_err)这两个软件。

你的命令没有问题。 rpm-5.1.6.tar.gz不是rpm包,是一个gz的压缩包,用tar -xzvf rpm-5.1.6.tar.gz是可以解压成功的。 如果你要装rpm包,应该是 rpm -ivh 包名,或者你那个rpm-5.1.6.tar.gz原本是rpm包,后来被重命名了,你用rpm -ivh rpm-5.1.6....

cd到你存放rpm文件包的目录 rpm -ivh linuxqq-v1.0.2-beta1.i386.rpm 安装时可能会遇到缺少包的错误。 rpm -ivh --replacepkgs webmin-1.290-1.noarch.rpm 软件包重复安装将会失败,若仍需要安装必须加--replacepkgs rpm -ivh --replacefiles we...

你这几个不是针对你当前系统的包吧? 这几个依赖都算是是基本库,应该你的系统自带了。你这可能是版本不对应导致 so 后面的那个接口版本号不一致。 rpm -q 只是搜索他自己的数据库,这个数据库只有已经安装的软件书记。找不到的依赖,你再怎么用...

你把类似这个的rpm包安装一下 perl-5.10.1-136.el6.x86_64 我是redhat6.5的,你找下你centos7的perl的对应版本

dpkg --force-all -i *****.deb 忽悠依赖试试

网站首页 | 网站地图
All rights reserved Powered by www.mshd.net
copyright ©right 2010-2021。
内容来自网络,如有侵犯请联系客服。zhit325@qq.com