mshd.net
当前位置:首页 >> mAvEn 找不到 依赖 >>

mAvEn 找不到 依赖

如果全用私服的话,那让nexus的维护人员加进去,然后删除没jar包的文件夹内容,重新编译。如果找不到维护人员,可以到网上直接下载对应的jar包,复制到指定版本的目录中也行。

有很多可能呀,比如 1, 由于国内墙的问题,经常连不上 central 库。 2, 可能 groupid 或 artifactid 写错了 。 3. 不在 central 库里面。需要额外添加 依赖库。

org.apache.maven.plugins maven-compiler-plugin 2.3.2 1.6 1.6 UTF-8 org.apache.maven.plugins maven-jar-plugin true lib/ com.abc.ABCTest -->入口类名 org.apache.maven.plugins maven-dependency-plugin copy install copy-dependencies...

你检查下: 父工程里pom.xml中有个 app-service app-web,因为app-web依赖app-service,那么app-web要在app-service前面,这样先编译的内容才能被后面的依赖应用。

不自动搜索需要手动更新一下index。 具体操作步骤如下: 1、选择myeclipse->preferences->maven->installations 2、在弹出的窗口中选择user setting 选项为:D:\m2\repository\settings.xml,并点击update settings。并点击下面的reindex按钮更...

如在eclipse+maven编写mapreduce代码,就会报Missing artifactjdk.toos:jdk.toos:jar:1.6 只需要在项目的pom.xml 文件中加入以下配置,指定maven去本地寻找 tools.jar、 jdk.tools jdk.tools 1.6 system ${JAVA_HOME}/lib/tools.jar

直接在官网地址(http://mvnrepository.com/)中进行搜索最新jar即可。 譬如输入:struts2,然后点击search,找到struts2,点击链接进去,就会看到很多版本,选择你想要的版本,譬如2.3.4,点击进去,就能看到: 把它拷贝到pom.xml,保存,eclips...

那你JDK版本改了吗?配置好了吗?如果JDK版本改了的话,那看看jar路径是否有打红叉的。

所有的maven project都有一个pom.xml文件, 打开pom.xml,找到dependency tag:所在的位置; 然后到 maven repository中找到你所需要的包; 进入jar包,点选相应的版本,然后页面中就会有加入maven project的dependency,类似下面的内容: [html...

不太明白你的这个项目结构,从我的理解,是不是在 user-dao 这个模块的pom.xml里面,写了user-core的依赖,即dependency标签 如果写了,你需要先mvn install user-core 当然前提,mvn install user-core需要执行正确!!这个很重要!

网站首页 | 网站地图
All rights reserved Powered by www.mshd.net
copyright ©right 2010-2021。
内容来自网络,如有侵犯请联系客服。zhit325@qq.com