mshd.net
当前位置:首页 >> struts2 2.5.8导入哪些jAr包 >>

struts2 2.5.8导入哪些jAr包

创建Struts2项目,首先必须要加载必要类库,因为Struts版本的不同,需要配置的类库就会有所差别。下面以我下载的Struts2.3.24版本为例,需要添加如下jar包: asm-3.3.jar asm-commons-3.3.jar asm-tree-3.3.jar commons-fileupload-1.3.1.jar 关...

这个整合和myeclipse版本没什么关系 只要遵循一下步骤 需要的包: commons-fileupload-1.2.jar commons-io-1.3.1.jar commons-logging-1.1.jar freemarker-2.3.8.jar junit-3.8.2.jar log4j-1.2.14.jar mysql-connector-5.1.7.jar ognl-2.6.11.ja...

最容易错的就是。你的struts.xml中的 这个部分一定要与你的struts2的版本对应的一样。建议你下载官方的包,官网 http://struts.apache.org/download.cgi#struts2181 下载truts-2.1.8.1-all.zip (110mb) [PGP] [MD5] 解压找到wapps文件。然后找到...

struts2-json-plugin-2.1.8.1.jar 这个是跟struts配套使用的 jsonplugin-0.34.jar 这个是单独使用的 如果要跟struts整合必须用第一个,如果单纯用json的话,两个应该都差不多,但最好用第二个

类没找到,jar包没加进去。你使用快捷键ctrl +shift+T,输入StrutsPrepareAndExecuteFilter ,看有没有这个类。 或者在web.xml文件中,按住ctrl键,鼠标看能不能点击进去

少了JAR包埃commons-lang.jar

java6是语言,哪有语言不支持库的... 而且struts的版本更新后必然是支持更新的版本的java,java6不可能不支持 你的问题应该是指struts和你项目下其他包不兼容,但从你的描述中是无法准确判断的

配置文件方法吗?

你把com.opensymphony.xwork2.Result强制转换成了org.apache.struts2.json.JSONResult类型?

在范围中,可以直接通过%{#foo}抓取参数 比如

网站首页 | 网站地图
All rights reserved Powered by www.mshd.net
copyright ©right 2010-2021。
内容来自网络,如有侵犯请联系客服。zhit325@qq.com