mshd.net
当前位置:首页 >> struts2需要用到那些包 >>

struts2需要用到那些包

普通的开发需要五个,ognl.jar,struts2-spring-plugin-2.x.jar,commons-logging-1.X.jar,struts2-core-2.x.jar,xwork-2.x.jar,freemark-2.x.jar。当然随着你的业务肯能需要更多的jar文件

早在struts2.0.*的时候,struts2的必备jar包需要如下几个: commons-logging-*.jar Apache旗下commons项目的log日志包 freemarker-*.jar 一种前台页面模板,应用比较广泛 ognl-*.jar 动态图导航语言,struts2处理前台页面的核心语言,相当实用 s...

看你要什么需求了,最基本的5个包不能少,分别是commons-logging-api-1.1.jar,freemarker-2.3.16.jar,ognl-3.0.jar,struts2-core-2.2.1.1.jar,xwork-core-2.2.1.1.jar 如果需要上传文件就需要commons-fileupload-1.2.1.jar,若要用到json则...

先把所有的struts文件下载,最基本的jar包(满足最简单struts运行起来的)可以去下载好的struts文件中struts-2.3.15.1-all\struts-2.3.15.1\apps\struts2-blank\WEB-INF\lib下去复制。其他的用到什么去struts-2.3.15.1-all\struts-2.3.15.1\lib...

你这些jar包够了啊,报什么错,再根据提示来加,宁少毋多,多了jar冲突很麻烦的

一般这五个包就够了freemarker-2.3.22.jar, ognl-3.0.6.jar, struts2-core-2.3.24.1.jar, commons-logging-1.1.3.jar, xwork-core-2.3.24.1.jar, 我的全部包是struts-2.3.24.1-all

strust2 官网,apache网站上有比较完整下载压缩包 ~ ~ ~

如果使用json-lib的话,依赖的jar包较多: commons-beanutils-1.8.0.jar commons-lang-2.5.jar commons-logging-1.1.1.jar json-lib-2.1.jar ezmorph-1.0.3.jar 以上的包可以在struts2完整的lib目录下面找到,版本号要看你下载的struts2的具体版...

我用的是struts2.2.1.1-all.zip(不管用struts2的哪个版本,道理都一样,找对应的包就行了) 例如你建一Web Project,名为Struts2 导入项目所需要的jar包,放入/Struts2/WebRoot/WEB-INF/lib下面 方法一: 在struts2存放目录(以我的举例说明) F:...

导入struts2-core-2.3.15.1.jar servletactioncontext 需要jar csdn的类型: 一 WEB容器在启动时,它会为每个WEB应用程序都创建一个对应的ServletContext对象,它代表当前web应用。 二 ServletConfig对象中维护了ServletContext对象的引用,开发...

网站首页 | 网站地图
All rights reserved Powered by www.mshd.net
copyright ©right 2010-2021。
内容来自网络,如有侵犯请联系客服。zhit325@qq.com