mshd.net
当前位置:首页 >> struts2.3.1 都需要那些jAr包? >>

struts2.3.1 都需要那些jAr包?

你这些jar包够了啊,报什么错,再根据提示来加,宁少毋多,多了jar冲突很麻烦的

只需要保留这个struts2-spring-plugin.jar:http://mvnrepository.com/artifact/org.apache.struts/struts2-spring-plugin/2.3.16.3

项目下面Referenced Libraries下struts2-core-2.2.3.jar下struts-default.xml里有声明,去复制下

java6是语言,哪有语言不支持库的... 而且struts的版本更新后必然是支持更新的版本的java,java6不可能不支持 你的问题应该是指struts和你项目下其他包不兼容,但从你的描述中是无法准确判断的

commons-fileupload-1.2.1.jar commons-io-1.3.2.jar freemarker-2.3.15.jar ognl-2.7.3.jar struts2-core-2.1.8.1.jar xwork-core-2.1.6.jar 这六个就可以了

ASM是小巧轻便的 Java 字节码操控框架 ,它能方便地生成和改造 Java 代码。

常用的差不多就是图中的了

你可以安装maven,可自动下载需要的版本,并且可查看各jar包依赖的jar包(自动加载)。

书上说的和你现在提问的问题是同一个版本的spring框架吗?spring2的时候只需要加入一个spring.jar就可以使用spring功能了.但是在spring3里面spring拆分成多个部分.根据你自己的需要添加相应的jar包.

网站首页 | 网站地图
All rights reserved Powered by www.mshd.net
copyright ©right 2010-2021。
内容来自网络,如有侵犯请联系客服。zhit325@qq.com